package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\*[[:alnum:]]{7})|([[:alnum:]]{8})`)
var str = `ECHOECHO
HS6THJLU
*THREEMA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}