$re = '/(\*[[:alnum:]]{7})|([[:alnum:]]{8})/m';
$str = 'ECHOECHO
HS6THJLU
*THREEMA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);