re = /(\s+[^a-z0-9]+|[^a-z0-9']+\s+|[\s&\/]|^)+(\w)/
str = 'title case split
world\'s title
fish&chips
(capitalize)'
subst = '$1[$2]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result