import re
regex = re.compile(r".*\.(\w{3,})$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("http://www.w3schools.com/jsref/jsref_regexp_exec.asp\n"
"https://translate.google.com/#en/pt/Thank%20you%20Engr!%20That%20is%20awesome.php\n"
"www.facebook.com/index.asp")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)