re = /.*\.(\w{3,})$/mi
str = 'http://www.w3schools.com/jsref/jsref_regexp_exec.asp
https://translate.google.com/#en/pt/Thank%20you%20Engr!%20That%20is%20awesome.php
www.facebook.com/index.asp'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result