package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<port>[1-9]{1,4}|[1-5][\d]{1,4}|6[0-5]{2}[0-3][0-5])$`)
var str = `1
65536
65535`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}