// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<port>[1-9]{1,4}|[1-5][\d]{1,4}|6[0-5]{2}[0-3][0-5])$").unwrap();
let string = "1
65536
65535";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}