$re = '/(?:\?|\&)(?<key>[\w]+)=(?<value>[\w+,.-]+)(?:\:?)(?<option>[\w,]*)/';
$str = 'http://www.regexlib.com/Search.aspx?k=URI&c=2&m=-1&ps=20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);