re = /(?:\?|\&)(?<key>[\w]+)=(?<value>[\w+,.-]+)(?:\:?)(?<option>[\w,]*)/
str = 'http://www.regexlib.com/Search.aspx?k=URI&c=2&m=-1&ps=20'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end