$re = '/(?<scheme>\w+):\/\/((?<user>\w+)(\:(?<password>[^\/:]+))?@)?(?<hostname>[\w-.]+)(:(?<port>\d+))?\/(?<request>(?<path>[^#\s\?]+)(\?(?<query>[^#\s]+))?(#(?<fragment>[^#\s]+))?)?/';
$str = 'https://example.org/absolute/URI/with/absolute/path/to/resource.txt
https://example.org/absolute/URI/with/absolute/path/to/resource.txt?a=alpha&b=bravo#bookmark
https://username:password@example.org:443/absolute/URI/with/absolute/path/to/resource.txt?a=alpha&b=bravo#bookmark
ftp://example.org/resource.txt
ftp://johndoe@example.org/resource.txt
ftp://janedoe:pa$$word@example.org/resource.txt
urn:ISSN:1535–3613
https://example.org/absolute/URI/with/absolute/path/to/resource.txt
https://username@example.org:443/absolute/URI/with/absolute/path/to/resource.txt?a=alpha&b=bravo#bookmark
https://username:password@example.org/absolute/URI/with/absolute/path/to/resource.txt?a=alpha&b=bravo#bookmark
https://username:pa$$w0rd@example.org:443/absolute/URI/with/absolute/path/to/resource.txt?a=alpha&b=bravo
//example.org/scheme-relative/URI/with/absolute/path/to/resource.txt
https://username:pa$$w0rd@example.org:443/absolute/URI/with/absolute/path/to/resource.txt#chap01
relative/path/to/resource.txt
../../../resource.txt
./resource.txt#frag01
resource.txt
#frag01
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);