$re = '/rain\s*(.*)/';
$str = 'The rain in Spain falls mainly in the plain';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);