package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\>)([^<]*?)(?:\<)`)
var str = `<div style='color: #FF0000;'>
<div style='font-weight:700;'>
<div>
<span> FOO </span> <span> FOO </span>
<span> FOO </span> <span> FOO </span>
</div>
</div>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}