$re = '/(?:\>)([^<]*?)(?:\<)/';
$str = '<div style=\'color: #FF0000;\'>
<div style=\'font-weight:700;\'>
<div>
<span> FOO </span> <span> FOO </span>
<span> FOO </span> <span> FOO </span>
</div>
</div>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);