using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?:\/\/)?(www[.])?linkedin[.]com\/profile\/[\w?&=0-9]+id=[0-9]+";
string input = @"http://www.linkedin.com/profile/view?id=292786434&trk=nav_responsive_tab_profile_pic";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}