$re = '/^(https?:\/\/)?(www[.])?linkedin[.]com\/profile\/[\w?&=0-9]+id=[0-9]+/i';
$str = 'http://www.linkedin.com/profile/view?id=292786434&trk=nav_responsive_tab_profile_pic';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);