using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((""[a-zA-Z0-9\-\_\@,\.:\$*]+""|[0-9]+)=>(""(.*)""|[0-9]+),?)+$";
string input = @"""o""=>""1"",";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}