#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:[a-zA-Z]*\.)+([a-zA-Z]+)(?:\/.*)?"
Local $sString = "172.15.3" & @CRLF & _
"" & @CRLF & _
"g-g.fr" & @CRLF & _
"http://www.google.com" & @CRLF & _
"google.fr" & @CRLF & _
"com.google.fr/test/" & @CRLF & _
"google.fr/test.html" & @CRLF & _
"g.g.g/g.g"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)