package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[a-zA-Z]*\.)+([a-zA-Z]+)(?:\/.*)?`)
var str = `172.15.3
g-g.fr
http://www.google.com
google.fr
com.google.fr/test/
google.fr/test.html
g.g.g/g.g`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}