#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?<=\]\s)(?:word1|word2)|(?:word1|word2)(?=\s\[))"
Local $sString = "] word1" & @CRLF & _
"word2 [" & @CRLF & _
"] word1 [" & @CRLF & _
"] word2 [" & @CRLF & _
"word1" & @CRLF & _
"word2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")