re = /((?<=\]\s)(?:word1|word2)|(?:word1|word2)(?=\s\[))/
str = '] word1
word2 [
] word1 [
] word2 [
word1
word2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end