import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#IPv4\n"
+ "(?<IPv4>\n"
+ " (?!0+\\.)\n"
+ " (?<byte>2(?:[0-4]\\d|5[0-5])|1?\\d{1,2})\n"
+ " (?:\\.(?&byte)){3}\n"
+ ")\n\n"
+ "#IPv6 from http://vernon.mauery.com/content/projects/linux/ipv6_regex\n"
+ "| (?<smb>[0-9a-f]{1,4}:){1,1} (?<sme>:[0-9a-f]{1,4}){1,6}\n"
+ "| (?&smb){1,2} (?&sme){1,5}\n"
+ "| (?&smb){1,3} (?&sme){1,4}\n"
+ "| (?&smb){1,4} (?&sme){1,3}\n"
+ "| (?&smb){1,5} (?&sme){1,2}\n"
+ "| (?&smb){1,6} (?&sme){1,1}\n"
+ "| ((?&smb){1,7}|:):\n"
+ "| :(?&sme){1,7}\n"
+ "| (?&smb){6} (?&IPv4)\n"
+ "| (?&smb){5} :?+ [0-9a-f]{1,4} :(?&IPv4)\n"
+ "| (?&smb){1,1} (?&sme){1,4} :(?&IPv4)\n"
+ "| (?&smb){1,2} (?&sme){1,3} :(?&IPv4)\n"
+ "| (?&smb){1,3} (?&sme){1,2} :(?&IPv4)\n"
+ "| (?&smb){1,4} (?&sme){1,1} :(?&IPv4)\n"
+ "| ((?&smb){1,5}|:) :(?&IPv4)\n"
+ "| :(?&sme){1,5} :(?&IPv4)\n";
final String string = "Valid\n"
+ "192.168.1.1\n"
+ "192.168.255.255\n\n"
+ "Invalid\n"
+ "0.0.0.0\n"
+ "0.0.0.1\n"
+ "0.0.0.255\n"
+ "1.0.0.255\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}