$re = '/#IPv4
(?<IPv4>
(?!0+\.)
(?<byte>2(?:[0-4]\d|5[0-5])|1?\d{1,2})
(?:\.(?&byte)){3}
)
#IPv6 from http://vernon.mauery.com/content/projects/linux/ipv6_regex
| (?<smb>[0-9a-f]{1,4}:){1,1} (?<sme>:[0-9a-f]{1,4}){1,6}
| (?&smb){1,2} (?&sme){1,5}
| (?&smb){1,3} (?&sme){1,4}
| (?&smb){1,4} (?&sme){1,3}
| (?&smb){1,5} (?&sme){1,2}
| (?&smb){1,6} (?&sme){1,1}
| ((?&smb){1,7}|:):
| :(?&sme){1,7}
| (?&smb){6} (?&IPv4)
| (?&smb){5} :?+ [0-9a-f]{1,4} :(?&IPv4)
| (?&smb){1,1} (?&sme){1,4} :(?&IPv4)
| (?&smb){1,2} (?&sme){1,3} :(?&IPv4)
| (?&smb){1,3} (?&sme){1,2} :(?&IPv4)
| (?&smb){1,4} (?&sme){1,1} :(?&IPv4)
| ((?&smb){1,5}|:) :(?&IPv4)
| :(?&sme){1,5} :(?&IPv4)
/sxX';
$str = 'Valid
192.168.1.1
192.168.255.255
Invalid
0.0.0.0
0.0.0.1
0.0.0.255
1.0.0.255
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);