$re = '/[A-Z][a-z]{2} \d{1,2}, 201[1-4]/';
$str = 'Jan 5, 2011';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);