package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Jan(?:uary)?|Feb(?:ruary)|Marc?h?|Apr[il1]?[I1l]?|May|June?|July?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:tober)?|Nov(?:ember)?|Dec(?:ember)?|20[01]\d)`)
var str = `February 4 - March 23, 2015`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}