re = /(Jan(?:uary)?|Feb(?:ruary)|Marc?h?|Apr[il1]?[I1l]?|May|June?|July?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:tober)?|Nov(?:ember)?|Dec(?:ember)?|20[01]\d)/
str = 'February 4 - March 23, 2015'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end