#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<![,\.\ ])(?=[,\.]+)|(?<=[,\.])(?![,\.\ ])|(?<=[,\.])\ +(?![,\.\ ])|(?<![,\.\ ])\ +(?=[,\.][,\.\ ]+)|(?<![,\.\ ])\ +(?![,\.\ ])"
Local $sString = "This, I think,., کباب MAKES , some sense " & @CRLF & _
"This, I think,. , کباب MAKES , some sense " & @CRLF & _
"This, I think,. , کباب MAKES , some sense " & @CRLF & _
"This, I think, . ,کباب MAKES , some sense " & @CRLF & _
""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)