const regex = /\\(?!color)([^{]|(?<!color)\{)*\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\(?!color)([^{]|(?<!color)\\{)*\\}', 'gm')
const str = `text \\color{abc}text
text \\other{abc} text \\color{abc} text \\other{abc}
\\color{abc} \\footcites[abc]{hello}[abc]{abc} alkjöfalksdjfölaksdjföalksdjfölaksdjöfalksjdöflakdjsfölkj \\color{abc}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}