re = /\\(?!color)([^{]|(?<!color)\{)*\}/m
str = 'text \\color{abc}text
text \\other{abc} text \\color{abc} text \\other{abc}
\\color{abc} \\footcites[abc]{hello}[abc]{abc} alkjöfalksdjfölaksdjföalksdjfölaksdjöfalksjdöflakdjsfölkj \\color{abc}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end