import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\p{L}+\\s{1})*\\p{L}+$";
final String string = "Juan\n"
+ "Juan \n"
+ " Juan\n"
+ "Juan Ablerto\n"
+ "Juan Pablo\n"
+ "Juan Jose Pablo\n"
+ "Mañana Linda\n"
+ "María José\n"
+ "Roberto Güeno";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}