$re = '/^(\p{L}+\s{1})*\p{L}+$/m';
$str = 'Juan
Juan
Juan
Juan Ablerto
Juan Pablo
Juan Jose Pablo
Mañana Linda
María José
Roberto Güeno';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);