using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(?:<[^>]*>[[:blank:]]*){1}\K<[^>]*>";
string input = @"<this would be red> <this would be orange> <this would be yellow> <etc..>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}