re = /(?m)^(?:<[^>]*>[[:blank:]]*){1}\K<[^>]*>/m
str = '<this would be red> <this would be orange> <this would be yellow> <etc..>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end