package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?m)^(?:<[^>]*>[[:blank:]]*){1}(<[^>]*>)`)
var str = `<this would be red> <this would be orange> <this would be yellow> <etc..>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}