$re = '/(?m)^(?:<[^>]*>[[:blank:]]*){1}(<[^>]*>)/m';
$str = '<this would be red> <this would be orange> <this would be yellow> <etc..>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);