import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/(?<domain>[^\\/\\n]+)\\/[^\\?\\n]+[?](?<params>[^\\n]+)";
final String string = "http://site.com/index.php?id=1\n"
+ "http://site.com/index.php?id=2\n"
+ "http://site.com/index.php?id=3\n"
+ "http://site.com/index.php?id=1¶m=a\n"
+ "http://site.com/index.php?id=1¶m=b&year=2015\n"
+ "http://site2.com/index.php?id=3\n"
+ "http://site2.com/index.php?id=4\n"
+ "http://site2.com/index.php?id=5\n"
+ "http://site2.com/index.php?id=1¶m=x\n"
+ "http://site2.com/index.php?id=1¶m=y\n"
+ "http://site2.com/index.php?id=3¶m=z";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}