import re
regex = re.compile(r"http:\/\/(?<domain>[^\/\n]+)\/[^\?\n]+[?](?<params>[^\n]+)")
test_str = ("http://site.com/index.php?id=1\n"
"http://site.com/index.php?id=2\n"
"http://site.com/index.php?id=3\n"
"http://site.com/index.php?id=1¶m=a\n"
"http://site.com/index.php?id=1¶m=b&year=2015\n"
"http://site2.com/index.php?id=3\n"
"http://site2.com/index.php?id=4\n"
"http://site2.com/index.php?id=5\n"
"http://site2.com/index.php?id=1¶m=x\n"
"http://site2.com/index.php?id=1¶m=y\n"
"http://site2.com/index.php?id=3¶m=z")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")