using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\[,])[^\],]*(,)";
string input = @"[TEXT1,TEXT2,TEXT3],[TEXT1,TEXT2,TEXT3],[TEXT1,TEXT2,TEXT3]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}