re = /(?<=[\[,])[^\],]*(,)/
str = '[TEXT1,TEXT2,TEXT3],[TEXT1,TEXT2,TEXT3],[TEXT1,TEXT2,TEXT3]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end