import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/.*?\\.pdf";
final String string = "omberg. Retrieved September 3, 2010.\n"
+ "Jump up ^ Bloomberg August 4, 2010 article.\n"
+ "Jump up ^ Lauerman, John (April 2, 2014). \"Apollo Falls as Education Department Demands Records\". Bloomberg News. Retrieved May 1, 2014.\n"
+ "Jump up ^ \"Why Recent Criticism of the University of Phoenix is Unjustified, Rhonda P. Urban, Ementor, ezine by Warsaw School of Economics\". E-mentor.edu.pl. Retrieved September 3, 2010.\n"
+ "Jump up ^ \"University of Phoenix 2007 Fact Book\". Phoenix.edu. Retrieved September 3, 2010.\n"
+ "Jump up ^ \"U. of Phoenix Says Test Scores Vindicate Its Academic Model, Chronicle of Higher Education, BLUMENSTYK June 13, 2008\" (PDF). Upxnewsroom.com. Retrieved September 3, 2010.\n"
+ "Jump up ^ \"University of Phoenix Ranks #1 in Graduating Master's Degree Students from Underrepresented Populations, Hispanic PR Wire\". Hispanicprwire.com. July 18, 2007. Retrieved September 3, 2010.\n"
+ "Jump up ^ Nealy, Michael (August 20, 2009). \"Pride and Peril: Historically Black Colleges and Universities\". Diverse – Issues in Higher Education. Retrieved September 25, 2009.\n"
+ "Jump up ^ Jennifer H. Svan. \"DOD renews contracts with four schools, drops University of Phoenix – News\". Stripes. Retrieved October 5, 2013.\n"
+ "Jump up ^ University of Phoenix Faculty Overview. Retrieved February 17, 2008.\n"
+ "Jump up ^ \"Supporting E-Learning at the University of Phoenix\" (PDF). Retrieved September 3, 2010.\n"
+ "^ Jump up to: a b \"Faculty\". phoenix.edu.\n"
+ "Jump up ^ \"Search Results\". Adjunct Project.\n"
+ "Jump up ^ \"Howard Schmidt, Cybersecurity 'Czar': Who Is He?\". The Christian Science Monitor. Retrieved December 29, 2009.\n"
+ "Jump up ^ Adams, Marilyn (February 5, 2008). \"Events, Drive Keep DOT Chief in the Spotlight\". USA Today. Retrieved September 3, 2010.http://somethink.pdf\n"
+ "Jump up ^ \"Brad L. Dee\". Utah House of Representatives. Retrieved December 15, 2010.\n"
+ "Jump up ^ United States Navy Biography U.S. Navy Web Site. Retrieved March 13, 2008.\n"
+ "Jump up ^ \"Mayor Bill White Announces Police Chief Nominee\". City of Houston. February 27, http://RetrievedDecember.pdf 15, 2010.\n"
+ "Jump up ^ \"Christina Brown\". MSNBC. 2010. Retrieved December 15, 2010.\n"
+ "Jump up ^ The Big Executive? Shaq masters MBA MSNBC Web Site. Retrieved February 12, 2008.\n"
+ "Jump up ^ Los Angeles Sparks Lisa Leslie Receives her Masters at University of Phoenix WireImage Website. Retrieved March 20, 2009.\n"
+ "Jump up ^ \"Michael Russell completes undergrad program from University of Phoenix\". Tennisworldusa.org. January 15, 2012. Retrieved November 11, 2013.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}