// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"http:\/\/.*?\.pdf").unwrap();
let string = "omberg. Retrieved September 3, 2010.
Jump up ^ Bloomberg August 4, 2010 article.
Jump up ^ Lauerman, John (April 2, 2014). \"Apollo Falls as Education Department Demands Records\". Bloomberg News. Retrieved May 1, 2014.
Jump up ^ \"Why Recent Criticism of the University of Phoenix is Unjustified, Rhonda P. Urban, Ementor, ezine by Warsaw School of Economics\". E-mentor.edu.pl. Retrieved September 3, 2010.
Jump up ^ \"University of Phoenix 2007 Fact Book\". Phoenix.edu. Retrieved September 3, 2010.
Jump up ^ \"U. of Phoenix Says Test Scores Vindicate Its Academic Model, Chronicle of Higher Education, BLUMENSTYK June 13, 2008\" (PDF). Upxnewsroom.com. Retrieved September 3, 2010.
Jump up ^ \"University of Phoenix Ranks #1 in Graduating Master's Degree Students from Underrepresented Populations, Hispanic PR Wire\". Hispanicprwire.com. July 18, 2007. Retrieved September 3, 2010.
Jump up ^ Nealy, Michael (August 20, 2009). \"Pride and Peril: Historically Black Colleges and Universities\". Diverse – Issues in Higher Education. Retrieved September 25, 2009.
Jump up ^ Jennifer H. Svan. \"DOD renews contracts with four schools, drops University of Phoenix – News\". Stripes. Retrieved October 5, 2013.
Jump up ^ University of Phoenix Faculty Overview. Retrieved February 17, 2008.
Jump up ^ \"Supporting E-Learning at the University of Phoenix\" (PDF). Retrieved September 3, 2010.
^ Jump up to: a b \"Faculty\". phoenix.edu.
Jump up ^ \"Search Results\". Adjunct Project.
Jump up ^ \"Howard Schmidt, Cybersecurity 'Czar': Who Is He?\". The Christian Science Monitor. Retrieved December 29, 2009.
Jump up ^ Adams, Marilyn (February 5, 2008). \"Events, Drive Keep DOT Chief in the Spotlight\". USA Today. Retrieved September 3, 2010.http://somethink.pdf
Jump up ^ \"Brad L. Dee\". Utah House of Representatives. Retrieved December 15, 2010.
Jump up ^ United States Navy Biography U.S. Navy Web Site. Retrieved March 13, 2008.
Jump up ^ \"Mayor Bill White Announces Police Chief Nominee\". City of Houston. February 27, http://RetrievedDecember.pdf 15, 2010.
Jump up ^ \"Christina Brown\". MSNBC. 2010. Retrieved December 15, 2010.
Jump up ^ The Big Executive? Shaq masters MBA MSNBC Web Site. Retrieved February 12, 2008.
Jump up ^ Los Angeles Sparks Lisa Leslie Receives her Masters at University of Phoenix WireImage Website. Retrieved March 20, 2009.
Jump up ^ \"Michael Russell completes undergrad program from University of Phoenix\". Tennisworldusa.org. January 15, 2012. Retrieved November 11, 2013.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}