# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?(\w+\s+\d+,\s*(\d+))/$2 = $1\n/g;t' <<< "Weekly Comparison, Week 50 October 28 - November 3, 2016 October 30 - November 5, 2015"