# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?(\w+\s+\d+,\s*(\d+))"
test_str = "Weekly Comparison, Week 50 October 28 - November 3, 2016 October 30 - November 5, 2015"
subst = "$2 = $1\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.