const regex = /(?:(?<dateShort>\d\d\/\d\d\/\d{4})|(?<dateLong>\w* \d\d, \d{4})|(?<dateISO>\d{4}-\d\d-\d\d)).*label:\s(?<label>\w*)\)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<dateShort>\\d\\d\\\/\\d\\d\\\/\\d{4})|(?<dateLong>\\w* \\d\\d, \\d{4})|(?<dateISO>\\d{4}-\\d\\d-\\d\\d)).*label:\\s(?<label>\\w*)\\)', 'gmi')
const str = `2. Match all the dates in the following text, and label each date accordingly
Sent: 01/20/2023 at 10:00 AM (label: Sent)
To: Manuel
Don’t forget our meeting on Saturday, January 23, 2023 (label: Meeting), to discuss the following
schedules:
2023-01-27 - Unlocking the Secrets of RegEx: Learn to Match Patterns (label: Class1)
2023-01-28 - Unleashing the Potential of RegEx: Advanced Techniques (label: Class2)
2023-01-29 - Make and RegEx: Powering Up Your Automation Workflows (label: Class3)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}