import re
regex = re.compile(r"(?:(?<dateShort>\d\d\/\d\d\/\d{4})|(?<dateLong>\w* \d\d, \d{4})|(?<dateISO>\d{4}-\d\d-\d\d)).*label:\s(?<label>\w*)\)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("2. Match all the dates in the following text, and label each date accordingly\n"
"Sent: 01/20/2023 at 10:00 AM (label: Sent)\n"
"To: Manuel\n"
"Don’t forget our meeting on Saturday, January 23, 2023 (label: Meeting), to discuss the following\n"
"schedules:\n"
"2023-01-27 - Unlocking the Secrets of RegEx: Learn to Match Patterns (label: Class1)\n"
"2023-01-28 - Unleashing the Potential of RegEx: Advanced Techniques (label: Class2)\n"
"2023-01-29 - Make and RegEx: Powering Up Your Automation Workflows (label: Class3)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")