$re = '/(?=[-+][^-+]*$)/m';
$str = '\'-1.366-6\'
\'1.366-6\'
\'-1.366+6\'
\'1.366+6\'
\'-1.25-10\'';
$subst = "e";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;