import Foundation
let pattern = #"(?=[-+][^-+]*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'-1.366-6'
'1.366-6'
'-1.366+6'
'1.366+6'
'-1.25-10'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"e"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)