import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@if \\( (?P<condition>[^)]*) \\)\n"
+ " \\s*\n"
+ "(?P<content> [^@]*+ (?:@(?!endif\\b)[^@]*)*+ )\n"
+ "@endif";
final String string = "@if('0' == '0')\n"
+ " <div id=\"alert\" class=\"alert alert-danger\" style=\"display: inline-block\">fgh</div>\n"
+ "@endif\n"
+ "<form method=\"post\">\n"
+ "<button id=\"startLogik\" class=\"button\" type=\"submit\" name=\"start\">fgh</button>\n"
+ "</form>\n"
+ "@if('0' == '1')\n"
+ " <script type=\"text/javascript\">\n"
+ " Logik_SrvBsy = \"bsy\";\n"
+ " GetClientName();\n"
+ " Logik_Init(\"\", \"\", \"web\",\"test\",\"Start\");\n"
+ " Logik_SPar_fx(\"WEB_LOGIN.EMAIL\", \"mail@mail\");\n"
+ " Logik_SPar_fx(\"WEB_LOGIN.WEBID\", \"cvb\");\n"
+ " Logik_SPar_fx(\"WEB_LOGIN.LANG\", \"cvb\");\n"
+ " Logik_Exec_fx(\"Start\");\n"
+ "</script>\n"
+ "@endif";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}