$re = '~@if \( (?P<condition>[^)]*) \)
\s*
(?P<content> [^@]*+ (?:@(?!endif\b)[^@]*)*+ )
@endif~x';
$str = '@if(\'0\' == \'0\')
<div id="alert" class="alert alert-danger" style="display: inline-block">fgh</div>
@endif
<form method="post">
<button id="startLogik" class="button" type="submit" name="start">fgh</button>
</form>
@if(\'0\' == \'1\')
<script type="text/javascript">
Logik_SrvBsy = "bsy";
GetClientName();
Logik_Init("", "", "web","test","Start");
Logik_SPar_fx("WEB_LOGIN.EMAIL", "mail@mail");
Logik_SPar_fx("WEB_LOGIN.WEBID", "cvb");
Logik_SPar_fx("WEB_LOGIN.LANG", "cvb");
Logik_Exec_fx("Start");
</script>
@endif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);