#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<%image\((.*)\|.*\|.*\|\)%>"
Local $sString = "<%image(20100213-na-de-les-mag-hij-even-blijven.jpg|120|120|)%>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")