using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*<\?php(?:.(?!\?>\s*$))*$";
string input = @"<?php or whitespace<?php and NOT end with ?> or ?>
whitespace.?> ";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}